Find Questions…

Close ×
First time here? Check out the FAQ!

"Backup Service": Could not load output factory

Tobias Hoffmann asked this question · 31 karma ·

After installing a few plugins, I'm getting this error:

Backup Service [service.services.export.ExportService] An exception while running the export service "Backup Service": Could not load output factory
com.atlassian.dbexporter.node.stax.XmlFactoryException: Could not load output factory
at com.atlassian.dbexporter.node.stax.StaxUtils.newXmlOutputFactory(StaxUtils.java:182)
at com.atlassian.dbexporter.node.stax.StaxStreamWriter.createXmlStreamWriter(StaxStreamWriter.java:53)
at com.atlassian.dbexporter.node.stax.StaxStreamWriter.<init>(StaxStreamWriter.java:39)
at com.atlassian.activeobjects.backup.ActiveObjectsBackup.save(ActiveObjectsBackup.java:106)
at com.atlassian.jira.bc.dataimport.DefaultExportService.export(DefaultExportService.java:91)
at com.atlassian.jira.bc.dataimport.DefaultExportService.export(DefaultExportService.java:53)
at com.atlassian.jira.service.services.export.ExportService.performBackup(ExportService.java:136)
at com.atlassian.jira.service.services.export.ExportService.run(ExportService.java:121)
at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:60)
at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:47)
at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
at com.atlassian.multitenant.quartz.MultiTenantThreadPool$MultiTenantRunnable.run(MultiTenantThreadPool.java:72)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: javax.xml.stream.FactoryConfigurationError: Provider for com.sun.xml.internal.stream.XMLOutputFactoryImpl cannot be found
at javax.xml.stream.XMLOutputFactory.newFactory(XMLOutputFactory.java:215)
at com.atlassian.dbexporter.node.stax.StaxUtils.newXmlOutputFactory(StaxUtils.java:189)
at com.atlassian.dbexporter.node.stax.StaxUtils.newXmlOutputFactory(StaxUtils.java:178)
... 12 more


Any idea how to fix this?

503 views

Jeremy Largman [Atlassian] · 10,257 karma ·

What plugins did you install?

It might be related to https://jira.atlassian.com/browse/JRA-24856 but that's still not a root cause. We're tracking a blocker issue https://jira.atlassian.com/browse/JRA-25309 but that's for viewing a filter. Search your logs for those as well, otherwise try to narrow down which plugin is the culprit.

Tobias Hoffmann · 31 karma ·

I had installed the JIRA Gantt-Chart Plugin and JIRA Gantt Chart Project, but disabling both of them didn't change anything.

One Answer:

Tobias Hoffmann · 31 karma ·

It turned out that the problem disappeared when I switched from the Icedtea JDK to the Sun JDK.

Looking for something else?

Find Questions…

or Browse other questions tagged:

or Ask a Question