Hi all, just upgraded to Bamboo 4.0 build 2906 and imported my 3.4 project back in with no problem. Yeaayy!!

Our team is moving to an internally hosted Github:Enterprise server, so I pointed my repository at it using https://blahblah/blah/repo, but when i click on the Load Repositories button, it spins for a bit, buts loads nothing. I know the connectivity/etc. is good, since I can git clone the repo by hand.

Is the Source Repository tabs "Github pulldown" somehow defaulting to Github.com (which works btw) and not allowing me to go to an internal server?



  1. Keith Miller

    I'm very interested in this as well :)

CommentAdd your comment...

1 answer


    Yes it does default to github. You could try running Babmoo server with


    (check the url exists first).

    This should let you load repositories - checkout probably won't work though. One solution would be to make github.com resolve to your github host, another would be to change the com.atlassian.bamboo.plugins.git.GitHubRepository class and recompile it (it's pretty easy - the plugin is open source: https://github.com/atlassian/bamboo-git-plugin). You can even fork it and create a pull request for us ;-) .

    1. clellandc

      Hi Przemek, Thanks for the quick reply and great info!

      You are correct, using the -Dattlassian.bamboo.github.api.bas.url=
      allowed us to the see our Github Enterprise repo, but it would not let us do a clone.

      Next, I cloned https://github.com/atlassian/bamboo-git-plugin and modified the file GitHubRepository.java
      changing Github.com to use our Github Enterprise URL. Installed Maven 2.2.1 on Centos 6 and here's the output:

    2. Piotr Stefaniak

      Are you trying to rebuild/recompile the bamboo-git-plugin? If so you need to configure maven to use atlassian's public repositories - for me the easiest way to achieve that was to download atlassian-plugin-sdk (can you find it by yourself? I think it's pretty easy to discover it on the net) and use "atlas-mvn" tool contained in the sdk.

    3. clellandc

      Hi Piotr, I downloaded the atlassian plugin SDK, and tried a couple different things (both from within the bamboo-git-plugin root directory - where pom.xml is located):

      I found this post from a year ago where the same problem happened with the 3.1-SNAPSHOT file, but mine is with the 4.0-SNAPSHOT (https://github.com/atlassian/bamboo-git-plugin/issues/3/).

      I looked for the the missing file, but was unable to locate it.

      Also tried this:

      I seem to be getting closer, and I really appreciate the help I've got so far on this site.


    4. Piotr Stefaniak

      Try changing in the pom.xml the bamboo.version from 4.0-SNAPSHOT to 4.0. https://github.com/atlassian/bamboo-git-plugin/blob/master/pom.xml#L181 .

    5. clellandc

      That worked!! It just finished building successfully.

      Thanks so much for your help... everybody have a great weekend. :-)

    CommentAdd your comment...