1
0
-1

Hello,

I configured the server and get this exception when sending mails:

    CommentAdd your comment...

    3 answers

    1.  
      3
      2
      1

      HELO usually requires fully qualified domain name. In this case, most probably the source machine (your confluence host) does not have set a fully qualified name; set this and try again.

      Edit:

      Excerpt from http://www.oracle.com/technetwork/java/faq-135477.html :

      Q: I get "MessagingException: 501 HELO requires domain address" when trying to send a message.
      A: The SMTP provider uses the results of InetAddress.getLocalHost().getHostName() in the SMTP HELO command. If that call fails to return any data, no name is sent in the HELO command. Check your JDK and name server configuration to ensure that that call returns the correct data. You may also set the "mail.smtp.localhost" property to the name you want to use for the HELO command.

      1. Arantxa Lacasa Madero

        Hello,

        Where do I have to set the fully qualified name?

        Where is Confluence getting this value from?

        Please, could you tell me step by step how to configure that?

        Thanks!

      2. Arantxa Lacasa Madero

        Our smtp server does not verify the host name machine. Hostname is ip-192-168-X-XX, but smtp does not verify it. We tested it sending whatever and it does not give any error. It only gives error when hostname goes empty.

        Can it be sending it empty? If sending ip-192-168-X-XX, it should not fail.

        Is there any way I can know what is sending?

      3. Radu Dumitriu

        Do this test:

        Compile the folowing Cucu.java:

        =========

        ===========

        If this prints empty host name, this is your problem.

      4. Arantxa Lacasa Madero

        Great, that was the problem and now it is solved.

        I appreciate a lot all your help!!

      CommentAdd your comment...
    2.  
      2
      1
      0

      Hi Arantxa,

      If configuring via the UI is not working you can configure a JNDI mail session and use that instead. Follow the instructions for GMail at http://confluence.atlassian.com/display/CONF35/How+do+I+configure+Confluence+to+use+GMail+as+the+mail+server and subsitute the relevant values for your mail server.

      Hope that helps,

      Andrew.

        CommentAdd your comment...
      1.  
        1
        0
        -1

        I think the key problem is:

        Caused by: javax.mail.MessagingException: 501 Command "HELO" requires an argument
        Which probably means when you clicked on the test button you forgot to include information it needs to conduct the test mail message.
        My best guess is you missed inputting some important information into the configuration. I guess you could post exactly how you configured it.
        1. Arantxa Lacasa Madero

          I configured the server from the "site administration", with the option "server configuration".

          I fill the fields:

          • Name: SMTP Server
          • From Adress: confluence@domain.com
          • From Name: Confluence
          • Subject Prefix: [confluence]
          • SMTP Server Hostname: Our smtp server hostname: port (this is wel configured)
          • User name and Password: We leave it in blank because no user name and pass are needed.

          When I test it, the body of the message is:

          This is a test message from Confluence.

          Server: SMTP Server

          From: confluence@abengoa.com

          Host User Name: null (because we don't need user name)

          When sending, it keeps thinking and at least it says the error that I posted before in the log.

          What am I doing wrong?

          Is there anywhere else where I can configure server? Any property file, or something?

          Thanks for your help!

          Arantxa.

        CommentAdd your comment...