Find Questions…

Close ×
First time here? Check out the FAQ!

Attachment version history isn't displayed

Sherry Xie asked this question · 346 karma ·

after upgrade confluence to 3.5.13, the attachment screen (under tools) isn't displayed attachment version history.

I used "edit in office" link to edit the document and after saved the document, no attachment version history can be displayed, there is no icon for me to hide or unhide the version history.

Any help? Thanks

512 views

3 Answers:

Alison Reid · 31 karma ·

Sherry, I am experiencing the same thing you are in Firefox (10.0.2) and IE (8 with compatibility view). However, I can see the arrow and can toggle it open to see past versions in Chrome (17.0.963.56) and IE (8 without compatibility view). You might see if a different browser helps.

However, in those two browsers that show the toggle, the icons are messed up. You can actually see a down arrow, a right arrow, a trash can, a pencil, and a gear. (see screenshot attached) They all function as the toggle to show attachment versions... they don't actually edit, delete, etc. Maybe the developers were planning a UI enhancement that didn't get finished. But that's a small concern for me - I was simply glad to see that I could view the previous versions.

Sherry Xie · 346 karma ·

Thanks a lot! I tried google Chrome and it works.

Hanis Suhailah [Atlassian] · 4,337 karma ·

When viewing a list of attachments, a new version of an existing attachment can be added simply by uploading an attachment with the same filename on the attachment view. Click the blue arrow next to an attachment to display previous versions of the attachment.

Existing files will be kept with the name 'Version x', where the value of 'x' increments with each upload of an attachment with the same filename.

For details you may refer here: http://confluence.atlassian.com/display/CONF35/Attachment+Versions

Sherry Xie · 346 karma ·

thanks for your information. My problem is - after uploading an attachment with the same filename or using "edit in office" link and saved the document, there is no blue arrow next to the attachment as expected.

Is this a bug in confluence?

Jerre Wattimury · 1 karma ·

Hi there,

Im experiencing the same issue. Im using the attachment macro on a page. Altough I have multiple versions of one document the macro only shows the newest one. I can see the + symbol, but when click on it, the macro wont show me a version tree..

I have tested multiple browsers on both Windows and Mac.. and updated all my plugins, software etc.. is this a bug? When I go to the normale attachment overview



Sherry Xie · 346 karma ·

Hi Jere,

My problem is with browser, so it is a bug. If you have tried on different browsers and all displayed the same, I think you may need to check the macro on the page. You may refer to the details of attachment macro below, include parameter OLD to display history of the attachment:

http://confluence.atlassian.com/display/CONF27/Displaying+List+of+Attachments+in+a+Page

hope this help you.

Looking for something else?

Find Questions…

or Browse other questions tagged:

or Ask a Question