Find Questions…

Close ×
First time here? Check out the FAQ!

Entering in a password in SourceTree?

Senseful asked this question · 6 karma ·

I just upgraded to the latest version (I tried both 1.3.1 on the App Store and 1.3.2 on the website) and I'm having a problem when trying to push a change to a Google Code Git project. It says that I have an invalid username/password combination. I tried searching everywhere but can't find a place to type in my password for the repository. I even tried creating a new connection to the repostiory in hopes that it will ask me for authentication via a popup dialog or something similar, but I still get the exact same problem. It never asks me for a password for my repository, and I don't see a way to enter in a password.

6545 views

3 Answers:

Steve Streeting [Atlassian] · 14,675 karma ·

If you don't use SSH keys to authenticate (which are the most secure and convenient way), SourceTree intercepts password prompts from Git and provides a pop-up dialog - at least it does in every instance I've ever seen. I don't have any Google Code projects though, I've mostly tested this with GitHub, BitBucket, Gitorious and so forth. That said, they all work the same way.

If you're not getting a prompt, maybe the URL you're using already has the username & password embedded in it? That's a bad idea but if that's what you've got it might explain it.

Otherwise, when you do 'git push' on the command line, what prompts do you get?

Senseful · 6 karma ·

Awesome, thanks! The problem is that by default Google tells you to use a URL in the form of https://USER@code.google.com/p/PROJECT/, which was what I was using. However, after seeing your comment, I removed the "USER@" part and it now prompts me for both a username and password!

JBear822 · 1 karma ·

So, I never get a prompt when trying to push. I get this window that seems to prompt for a password, but I can't type in this window.

The "prompt" I can't type the password to

Need help with this. What's going on here?

OSX 10.7.5

SourceTree 1.6.3.1

JBear822 · 1 karma ·

So, I tried removing the username from the URL and I did get the prompt. However, the prompt apparently didn't do anything because it's still screaming for a username and password. Any help would be much appreciated.

now it inquires for both?

Looking for something else?

Find Questions…

or Browse other questions tagged:

or Ask a Question