1
0
-1

Hello,

We are having some problems reindexing maybe someone can help us:

Jira Version: 3.13.1

Error message: " Re-indexing is 91% complete. Current index: Issue
2012-01-31 06:21:52,755 JiraTaskExectionThread-1 WARN [NoModule] [SQLProcessor.commit]: SQL Exception occurred on commit. Error was:java.sql.SQLException: Communications link failure during commit(). Transaction resolution unknown.
2012-01-31 06:21:53,943 JiraTaskExectionThread-1 INFO [action.admin.index.IndexAdminImpl] Re-indexing finished
2012-01-31 06:21:58,630 indexerPool-1-thread-10 ERROR [jira.issue.index.MultiThreadedIssueIndexer] Exception indexing issue ..."

Issues: 30k

CustomFields: 200

users: 500

Database: MySql in the same server as Jira, the indexing process is launched from a local web browser.

Disk: Raid 5

The indexing process take about 9 hours, despite the long time it was working well last month, now, everytime we try to index, it fails at 91%. We have attachment index enabled, we always had it, usually it throw some errors.

We increase MySql "lock wait timeout" parameter to 360, but it didn't help.

Have someone experienced something similar?

Many thanks in advance.

    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      Hello marla,

      I feel You are on the right track for incresing the lock wait timeout

      There are 2 approaches to changing the lock wait time out :

      1. Increase the lock wait_timeout on MySQL server at the mysql prompt, for example:

      set global innodb_lock_wait_timeout = 360;

      The above query will increase the lock wait_timeout to 360 seconds.

      2. By using the MySQL Administrator tool , go to Startup Variables >> InnoDB Parameters. Then increase the Various - Lock Wait Timeout. You will be able to see the configuration file location at the bottom of the window.

      In addition to that, modify the configuration file of MySQL (Windows: my.ini or Unix:my.cnf) so that it will have the same setting every time the MySQL database is restarted.

      I hope this helps. Let me know.

      Amrut.

      1. Maria Maria

        Thank you Amrut for your answer, I'll try again this weekend and let you know.

        Marla

      2. Maria Maria

        Hi,

        We've tried increasing innodb paramenters, this weekend in both: testing and production environment, both fail at 91% (testing environment has a little less number of issues than production). The process does not index the last 200 issues.

        Testing environment as being a virtual machine take more than 24 hours to index, but it fails at 91% just as production.

        In testing environment we try changing the index location, but it fails at 91% too.

        Any help would be appreciated!

        Regards!

        Marla

      CommentAdd your comment...