Find Questions…

Close ×
First time here? Check out the FAQ!

Tomcat jira problem

Pursway asked this question · 1 karma ·

Does anyone saw the following error:

javax.management.MalformedObjectNameException: Cannot create object name for org.apache.catalina.connector.Connector

My Jira is not working now, I saw the error on the catalina log.

Thanks!

893 views

One Answer:

Nic Brough · 120,208 karma ·

Check the connector settings in Tomcat. Although if this is an OnDemand installation, I think you need to throw that back to support as you won't have access to that.

Pursway · 1 karma ·

in the server.xml file i have " <Connector port="8080" protocol="HTTP/1.1"

connectionTimeout="200000"

redirectPort="8443" />

"
Do you meen to that file?
Thanks.

Nic Brough · 120,208 karma ·

Yes, the error you are getting is usually to do with the connector settings in that file. But those look fine to me - standard off-the-shelf ones, so it must be something else.

What other errors are you getting - could you describe all the symptoms?

Pursway · 1 karma ·

Sure, Thanks.

I start the tomcat6 service on my rhel6, an try to got to the server:8080 - but I got empty page.

I tried to look at the logs: /var/log/tomcat6/catalina.out and /var/log/tomcat6/catalina.2012-01-19.log

and i see in both files the following exeption:

...

SEVERE: Error, processing connection

java.lang.IndexOutOfBoundsException

...

SEVERE: destroyMBeans: Throwable

javax.management.MalformedObjectNameException: Cannot create object name for org.apache.catalina.connector.Connector@214a7a12

Do you want any other information? just tell me what to do :)
Thanks!

Nic Brough · 120,208 karma ·

There's still not enough detail to tell from that, but you need to explain what you've done.

You imply it was running before - the question is therefore "what did you change" and then "what happens whwen you put it back the way you found it"

If I've misunderstood, and you've never had it running, can you explain how you installed it?

Pursway · 1 karma ·

I installed it, and it works fine,

I changed something on the apache web conf (added virtual web server) - but i tried to remove it and try the jira, with no help..

Does Jira and Tomcat using apache web server somehow?

Thanks..

Nic Brough · 120,208 karma ·

Well, they can use Apache - most places I've worked put Jira behind Apache for various reasons, and it works fine.

We've still got the problem that we really don't know what you've done, or changed, which is clearly the problem. As you've said it worked before, there must be something you've changed that broke it, and chasing that down is, I'm afraid, up to you. My next step would be to make sure Apache is not running at all and retry Jira. If Jira then works, then you need to focus on Apache. If it doesn't, then you need to go into more detail on what you changed in Jira.

Pursway · 1 karma ·

Hi,

Thanks for your help, I stoped apache web server, and restarted jira, with no help..

I have not changed anything else on the system..

Maybe I need to update the tomcat? i am using 6.0.24 .. and i saw this: https://issues.apache.org/bugzilla/show_bug.cgi?id=48612

Nic Brough · 120,208 karma ·

No. That version of Tomcat should be fine. Look at what has happened.

  1. You had a working Jira.
  2. You changed something.
  3. It stopped working.

Running off and blaming random problems in software that don't seem to relate to the errors in your logs probably won't hlpe much. I don't see how upgrading the Tomcat is going to help, unless it wipes out what you changed and puts it back to a working configuration. You have missed whatever it was you changed that broke it. By all means upgrade, but if you don't work out what you changed, you could easily break it again if you need to try whatever it was you did before.

Looking for something else?

Find Questions…

or Browse other questions tagged:

or Ask a Question