3
2
1

When I open the commit dialog there is a checkbox at the bottom of the screen to "Push commits immediately to [heroku]." Heroku is selected because it is the first repo in my list. The second repo is bitbucket. My question is: Is there a way to make heroku the second repo and bitbucket the first? I want to push commits immediately to bitbucket, but every time I open the commit dialog I have to select bitbucket instead of heroku at the bottom.

I tried removing heroku and re-adding it. That looked like it had fixed it, but when I brought up the commit screen the next time the order of the repos had switched again. Heroku always ends up at the top. How is that?

    CommentAdd your comment...

    10 answers

    1.  
      2
      1
      0

      SourceTree should be listing the remotes in the same order reported by 'git remote' - however it prefers a remote called 'origin' (for git) or 'default' (for hg), so if you rename the remote you use most to that then it will always be selected by default.

        CommentAdd your comment...
      1.  
        2
        1
        0

        Hm, that's not workting for me:

        Remote list in SourceTree

          CommentAdd your comment...
        1.  
          2
          1
          0

          Not working for me either.

          Sourcetree order:

          git remote order (alphabetical?):

          It would only be a minor annoyance if it was just the display order, but it seems like this order is used for things like the Push dialog, too. I don't want to accidentally be pushing branches to coworkers' remotes.

          The ability to customize the order via drag and drop would be ideal. Alternatively just using the order the remotes were added in sourcetree would be interesting. Prioritizing keywords like origin fork and trunk is another alternative but not very straightforward and what about subordering of origin, fork, trunk?

          Thanks!

            CommentAdd your comment...
          1.  
            1
            0
            -1

            This is actually a big problem for me as I have one repo I push to 99% of the time. Naturally the other one shows up on top. I had to just delete the 1% repo for now rather than accidentally push to it all the time.

            When I am able to push automatically after a commit it does go to the correct repo (the one the branch was created from). But when I have to use the push dialog it picks the wrong branch. Why is that?

            Please allow at least a default REPO, or if not set the order. Or pick the same repo in the push dialog that the commit + checkbox to automatically uses - if that makes sense.

              CommentAdd your comment...
            1.  
              1
              0
              -1

              Neither working like expected for me.

              git remote:

              1. bitbucket
              2. heroku

              on Sourcetree:

              1. heroku
              2. bitbucket

              Annoying to change the remote every single push. :/

                CommentAdd your comment...
              1.  
                1
                0
                -1

                The only thing that worked for me was renaming my primary repository to "origin".

                  CommentAdd your comment...
                1.  
                  1
                  0
                  -1

                  Renaming "trunk" to "origin" doesn't change the order for me.

                    CommentAdd your comment...
                  1.  
                    1
                    0
                    -1

                    This is an issue for me too, my case scenario is that I have two Git remotes (staging, production) and will like to set a default remote (the one I push 99% of the time) instead of choosing which remote everytime I push.

                      CommentAdd your comment...
                    1.  
                      1
                      0
                      -1

                      Any updates on this?

                      SourceTree remotes list definitely does not match the order listed via git remote...

                        CommentAdd your comment...
                      1.  
                        1
                        0
                        -1

                        What worked for me was going to 'Repository Settings' then click 'Edit Config File' and set the 'remote' property of the master branch to the alias of the repository I wanted it to select first.  See if this helps!

                          CommentAdd your comment...