1
0
-1

All,

I'm evaluating Jira. After installing I tried to access Jira from a web browser and it's not responding.

It responds to http://localhost:8080 and loads normally.

However, when I try to access it from a browser on another machine, http://<ip>:8080, I get no response.

I've also tried http://<machinename>:8080 and I get nothing.

If anyone has a suggestion it would be greatly appreciated.

Thanks!

  1. greg.annias

    I installed an open source product, which has an installer much like Jira. It runs on apache too. I can access it from any where on the internal network with no problems.

    I took the default Jira settings, could I be missing a config change some where?

  2. Nic Brough

    No, the problem is your network, not Jira. The fact that you can get to it on localhost:8080 tells you that Jira is running, accepting incoming connections and responding to them correctly. I suspect your "open source product" is running on another port, one that your network is not blocking automatically.

    So you need to fix your network.

  3. Shaun Parris

    Firewall issue for sure. Turned off my firewall and I was good to go.

CommentAdd your comment...

2 answers

  1.  
    1
    0
    -1

    If you are trying to access JIRA from an external (global) IP address, instead of your local host, you might not have port forwarding setup on your router to access it outside of your local area.

    Linksys example:

    To access it locally from any computer on your network

    192.168.0.XXX:PORT where XXX is the local IP to that machine (eg http://192.168.0.101:8080) - This would be the first thing to check out to make sure you can access it from other computers on your network. To find the local ip of the machine you need to do an ipconfig (eg windows start -> run -> ipconfig -- look @ IP Address there). If you can't access it locally from another machine on the network, you might want to check the firewall settings on the computer you are running JIRA on to make sure it's allowed.

    To access it globally, you'll need your real external IP (whatsmyip.net can give this to you - eg http://214.57.49.77:8080 --- random IP address i just typed FYI) If you can't access it that way, then you need to setup port forwarding on your router. You need to forward all port request (in this case 8080 for JIRA) to your local IP address. Linksys routers have a "Forwarding" area that's pretty explanitory. You enter the local IP address you want it to go to, the port number ranger (in this case both would be 8080), UDP/TCP/Both (use 'Both' if you aren't sure)

    Each router is different. But it sounds like your porblem is port forwarding.

      CommentAdd your comment...
    1.  
      1
      0
      -1

      That's a networking question really - something on the server, or in your network is stopping access.

      Start by checking the firewall settings on the Jira server and all machines between it (proxies and routers). A lot of installations block most ports by default and need adjusting to allow services to be accessed.

      1. luke ludington

        I am having the same problem and my firewall has been disabled.

      2. Nic Brough

        So what were the outcomes of all the debugging suggestions in this question?

      3. luke ludington

        the ping and telnet worked and ther server is still unaccessable.

      4. Nic Brough

        SO is Jira actually running? What do you get if you try to access it locally?

      5. luke ludington

        yes I get access to the site through localhost:8080

      6. luke ludington

        it says it cannot connect on port 23

      7. Nic Brough

        Then it's some firewall between your client computer (the browser) and the Jira server. When you say your firewall is off - you do mean on the Jira server?

        Could you tell us what happens if you try "Telnet <jira server> 8080"?

      8. Nic Brough

        No, it should have connected on port 8080, not 23 (23 is default for telnet)

        If your Jira is running and not firewalled by your network, it should respond to telnet on 8080 (it'll look rubbish, but that's fine, we're just interested in a response that returns data, or the error message explaining why not)

      9. luke ludington

        the connection still fails

      10. luke ludington

        I looked at the firewall and don't now what any of this means does any of this look out of place.

        [root@localhost ~]# iptables --list-rules
        -P INPUT ACCEPT
        -P FORWARD ACCEPT
        -P OUTPUT ACCEPT
        -N FORWARD_IN_ZONES
        -N FORWARD_IN_ZONES_SOURCE
        -N FORWARD_OUT_ZONES
        -N FORWARD_OUT_ZONES_SOURCE
        -N FORWARD_direct
        -N FWDI_public
        -N FWDI_public_allow
        -N FWDI_public_deny
        -N FWDI_public_log
        -N FWDO_public
        -N FWDO_public_allow
        -N FWDO_public_deny
        -N FWDO_public_log
        -N INPUT_ZONES
        -N INPUT_ZONES_SOURCE
        -N INPUT_direct
        -N IN_public
        -N IN_public_allow
        -N IN_public_deny
        -N IN_public_log
        -N OUTPUT_direct
        -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
        -A INPUT -i lo -j ACCEPT
        -A INPUT -j INPUT_direct
        -A INPUT -j INPUT_ZONES_SOURCE
        -A INPUT -j INPUT_ZONES
        -A INPUT -p icmp -j ACCEPT
        -A INPUT -j REJECT --reject-with icmp-host-prohibited
        -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
        -A FORWARD -i lo -j ACCEPT
        -A FORWARD -j FORWARD_direct
        -A FORWARD -j FORWARD_IN_ZONES_SOURCE
        -A FORWARD -j FORWARD_IN_ZONES
        -A FORWARD -j FORWARD_OUT_ZONES_SOURCE
        -A FORWARD -j FORWARD_OUT_ZONES
        -A FORWARD -p icmp -j ACCEPT
        -A FORWARD -j REJECT --reject-with icmp-host-prohibited
        -A OUTPUT -j OUTPUT_direct
        -A FORWARD_IN_ZONES -i enp7s0 -g FWDI_public
        -A FORWARD_IN_ZONES -g FWDI_public
        -A FORWARD_OUT_ZONES -o enp7s0 -g FWDO_public
        -A FORWARD_OUT_ZONES -g FWDO_public
        -A FWDI_public -j FWDI_public_log
        -A FWDI_public -j FWDI_public_deny
        -A FWDI_public -j FWDI_public_allow
        -A FWDO_public -j FWDO_public_log
        -A FWDO_public -j FWDO_public_deny
        -A FWDO_public -j FWDO_public_allow
        -A INPUT_ZONES -i enp7s0 -g IN_public
        -A INPUT_ZONES -g IN_public
        -A IN_public -j IN_public_log
        -A IN_public -j IN_public_deny
        -A IN_public -j IN_public_allow
        -A IN_public_allow -p tcp -m tcp --dport 22 -m conntrack --ctstate NEW -j ACCEPT

      11. Nic Brough

        I'm not a networking firewall expert, but it does look like that would block most incoming connections.

        Also, I thought you said it had been turned off? Could you try actually turning it off briefly to see if you can connect

      12. luke ludington

        I ran systemctl stop iptables.service I thought that it turned off the firewall but clearly it didn't. do you know of a better way to turn off the firewall in centos

      CommentAdd your comment...